RIP is a protocol that routers use to communicate and share information about what networks they are connected to. Every 30 seconds all the routers inform their neighbors the full list of networks they have, even if nothing has been changed since the last time.

This protocol counts the number of hops is necessary to get to the destination and after 15 hops the networks are considered unreachable. The version v1 (default) is obsolete, so always use v2.

Given the scenario below, PC1 needs to reach PC2:

In the example above v1 would not work, because it is classful (does not accept sub-networks) and the auto summarization of networks would also make it fail (while trying to merge the network IPs).

Router1

enable 
configure terminal
hostname Router1
no ip domain lookup
line con 0
logging synchronous

interface g0/0
ip address 192.168.3.1 255.255.255.252
no shutdown
interface g0/1
ip address 192.168.1.1 255.255.255.252
no shutdown

router rip
version 2
no auto-summary
network 192.168.3.0
network 192.168.1.0
passive-interface g0/1

Router2

enable 
configure terminal
hostname Router2
no ip domain lookup
line con 0
logging synchronous

interface g0/0
ip address 192.168.3.2 255.255.255.252
no shutdown
interface g0/1
ip address 192.168.2.1 255.255.255.252
no shutdown

router rip
version 2
no auto-summary
network 192.168.3.0
network 192.168.2.0
passive-interface g0/1

The router gateway to outside the network has to have this parameter set in the ‘router rip‘ config:

default-information originate

This will inform all the other routers who of them is the ‘gateway of last resort‘ when one network is unknown.

Also, use the command below to make all the interfaces passive by default and only activate the ones that you need:

passive-interface default
no passive-interface Serial0/0/0
no passive-interface Serial0/0/1

To check the configuration in each Router issue the commands:

show ip protocols
debug ip rip
show ip rip database
show ip rip neighbors

3 Replies to “RIPv2 on Cisco Routers”

Comments are closed.