EIGRP is a Cisco proprietary protocol to share between routers all the known networks and calculate the best path based on link-state, hops, and bandwidth. Each router only knows about its neighbors.

Given the scenario below, PC1 needs to reach PC2:

This image has an empty alt attribute; its file name is image-72.png

Router1

enable 
configure terminal 
hostname Router1
no ip domain lookup
line con 0
logging synchronous

interface g0/0
ip address 192.168.3.1 255.255.255.252
no shutdown
interface g0/1
ip address 192.168.1.1 255.255.255.0
no shutdown

router eigrp 10
no auto-summary
network 192.168.1.0 0.0.0.255
network 192.168.3.0 0.0.0.3
passive-interface g0/1

Router2

enable 
configure terminal 
hostname Router2
no ip domain lookup
line con 0
logging synchronous

interface g0/0
ip address 192.168.3.2 255.255.255.252
no shutdown
interface g0/1
ip address 192.168.2.1 255.255.255.0
no shutdown

router eigrp 10
no auto-summary
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.3
passive-interface g0/1

The router gateway to outside the network has to have this config:

ip route 0.0.0.0 0.0.0.0 g0/1

router eigrp 10
  network 0.0.0.0
  redistribute static

This will inform all the other routers who of them is the ‘gateway of last resort‘ when one network is unknown.

To check the configuration in each Router issue the commands:

do show ip eigrp neighbors
do show ip route eigrp
do show ip eigrp topology
do show ip protocols

Learn more about [EIGRP – CertBros]

The preview Post was about RIPv2 [Read It].

The following Post is about OSPF [Read It].

One Reply to “EIGRP on Cisco Routers”

Comments are closed.