GRE VPN is not a good VPN Tunneling technology and this is just a reference guide for information because does not offer much protection.

Near end:

interface tunnel 0
ip address 172.16.12.1 255.255.255.252
tunnel source g0/0
tunnel destination 10.2.2.1

Far end:

interface tunnel 0
ip address 172.16.12.2 255.255.255.252
tunnel source 10.2.2.1
tunnel destination 10.1.1.1

Useful commands for using it with IPv6 or mixed networks:

ipv6 unicast-routing (enables IPv6 routing)
do show ipv6 route (show the IPv6 routing table)
ipv6 address 2001:DB8:1:1::1/126 (set IPv6 to an interface)
tunnel mode gre ipv6 (defines GRE IPv6 for the interface)
tunnel mode ipv6ip (defines GRE IPv6 over IPv4 for the interface)

Also, see the RIPng (IPv6) post for additional information [Read It].

Read Also

Performance OpenVPN vs WireGuard [Link]

Setting Up WireGuard VPN [Link]

OpenVPN Server + Monitoring [Link]

pfSense with OpenVPN Client [Link]

2 Replies to “Point-to-Point GRE VPN Tunnel on Cisco Devices”

Comments are closed.