BGP (Border Gateway Protocol) is the routing protocol of the Internet, and because of the size of the global network, it is also the slowest.

It does not see each and all routers of the internet, but it knows how to get to ‘autonomous systems’, which means big network pools. Internet service providers are autonomous systems, big companies as Microsoft and Google are also autonomous systems.

This post is just for your information and will only assume the ISP configuration below that runs BGP and then joint the price network router to this BGP network:

hostname ISP
no ip domain-lookup
interface L0
ip address 10.10.10.10 255.255.255.255
interface Serial0/0/1
ip address 200.200.200.1 255.255.255.252
no shut
ip route 0.0.0.0 0.0.0.0 l0
router bgp 65001
bgp log-neighbor-changes
network 0.0.0.0
neighbor 200.200.200.2 remote-as 65000
end

Note: 10.10.10.10 just simulate the Internet in the ISP, 200.200.200.1 is the router address in the ISP network, 200.200.200.2 is the address of your network that is connected to the ISP (which means that the ISP router needs to be set to exchange routing information to your network).

Join your router to the ISP BGP network:

router bgp 65000
neighbor 200.200.200.1 remote-as 65001
network 200.100.100.0 mask 255.255.255.0

Note: 200.200.200.1 is the ISP address and 200.100.100.0 is the internal network you will advertise on the internet through the ISP router.

Useful command for troubleshooting:

show ip route
show ip bgp
show ip bgp summary

This post is just a quick reference guide for commands and I made it from the Cisco Lab 3.5.3.5. Consider searching for and reading the source material for additional information.